Thursday, 20 February 2014

HSRP Tracking

In previous blog we have seen if our primary router goes down backup router will provide redundancy. But there is some other possibility also.



Here R1 and R2 are client side router connected to R3 (ISP) router. R1 working as a Primary and R2 working as a secondary. Now what if "S1/1" of R3 goes down and still we don't have any configuration for this. So according to our previous configuration R1 still act like Primary. So with help of HSRP we can track our interfaces also.
Configuration-

R1(config)#int s 1/1

R1(config-if)#ip address 192.168.3.1 255.255.255.0

R1(config)#int f0/0

R1(config-if)#ip add 192.168.1.2 255.255.255.0
R1(config-if)#standby 1 ip add 192.168.1.1      //Virtual ip
R1(config-if)#standby 1 priority 105           // Making Primary
R1(config-if)#standby 1 preempt
R1(config-if)#standby 1 track serial 1/1


and on R2-

R2(config)#int s 1/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0

R1(config)#int f0/1

R1(config-if)#ip add 192.168.1.3 255.255.255.0
R1(config-if)#standby 1 ip add 192.168.1.1      //Virtual ip
R1(config-if)#standby 1 priority 100           //Making Secondary
R1(config-if)#standby 1 preempt
R1(config-if)#standby 1 track serial 1/0


Now go on R3 and shutdown S1/1. You'll R2 will become Primary.

Tuesday, 18 February 2014

Simple Redistribution Scenario









This task is very simple so do it. Only thing which may confuse some one why we are creating loopback interface as point-to-point. Then answer is by default OSPF doesn't take loopback as a real interface so if you are not creating it as point-to-point then it'll show the interface with /32 mask.So go in each and every loopback and do it as-

R2(config)#interface loopback 1

R2(config-if)#ip address 10.1.7.1 255.255.255.0
R2(config-if)#ip ospf point-to-point






* When we are redistributing routes in EIGRP and RIP we have to give metric value because by default both protocols take infinite metric.

* When we are redistributing is OSPF by default metric (seed metric) is 20. So if we are doing redistribution no need to provide metric until it doesn't ask. :P

* When we are redistributing is OSPF there are 2 option to set metric E1 and E2. By default it is E2 which means metric will not increase in network. We use it when there is only one way to go out. If we have multiple way then we'll use E1 which means metric is incremental in network. And now OSPF will decide which is better way.


* By default OSPF summarize redistributed network so we'll use 'subnet' when redistributing.

R2(config)#router ospf 1


R2(config-router)#redistribute eigrp 100 subnet

"Now check the metric type and metric on R3"

R2(config)#router eigrp 100
R(config-router)#redistribute ospf 1 metric 100 100 100 100 100


"Metric of EIGRP is little bit complex Bandwidth, Load, Delay, Reliability,MTU. So for now I am providing random values"


   






Here we need to filter routes. And here I am doing filtering using ACL.

Create ACL that permit odd numbered loopbacks.

R2(config)#access-list 1 permit 10.1.1.0 0.0.0.255
R2(config)#access-list 1 permit 10.1.3.0 0.0.0.255
R2(config)#access-list 1 permit 10.1.5.0 0.0.0.255

And apply it on OSPF.

R2(config)#router ospf 1
 

R2(config-router)#distribute-list 1 out
"Now look at routing table of R3"







Here we can also use ACL but we have one another better way to doing this that is by using prefix list.

First create a prefix-list-

R2(config)#ip prefix-list CCNP permit 10.0.0.0/8 le 24

"Now this prefix list allow only network 10.0.0.0 which have mask between 8-24"



Now we need to create route-map-

R2(config)#route-map FILTER_OSPF_TO_EIGRP //It's only route map name

R2(config-route-map)#match ip address prefix-list CCNP


"Rote map work like if-else statement in programming. Here we use Match-set statement. But by default if we are not providing any no and set statement then it start from 10 and permit"

Now apply this may in redistribution-

R2(config)#router eigrp 100
R2(config-router)#redistribute ospf 1 metric 100 100 100 100 100 route-map 
FILTER_OSPF_TO_EIGRP

All objective are done. If still you have any doubt and write your question in comment box or join our group for discussion on any point. Link of group is give in left side of page.

Thanks. Have a good day.

Monday, 17 February 2014

Implementing Basic EIGRP

Setup a lab in GNS as given in diagram. 
Configure all loopbacks on BB Router and also configure all the interface of BB, R2 and R3.

Now -

BB(config)#router eigrp 90
BB(config-router)#network 172.30.0.0 0.0.255.255
BB(config-router)#network 10.1.0.0 0.0.255.255
BB(config-router)#no auto-summary  //("By default RIP and EIGRP supports auto summary.")

R2(config)#router eigrp 90
R2(config-router)#no auto-summary
R2(config-router)#network 10.1.2.2 0.0.0.0
R2(config-router)#network 10.1.24.2 0.0.0.0
R2(config-router)#network 10.1.25.2 0.0.0.0 //("It is mentioned that use specific wild card mask")

R3(config)#router eigrp 90
R3(config-router)#no auto-summary
R3(config-router)#network 10.1.2.1 0.0.0.0
R3(config-router)#network 10.1.34.2 0.0.0.0

Now we need to create static route on BB.

BB(config)#ip route 192.168.1.0 255.255.255.0 null0
and
BB(config-router)#network 192.168.1.0

Now look at tables-
"show ip route"
"show ip eigrp neighbor"
"show ip eigrp topology"


BB(config)#ip default-network 192.168.1.0

No look at routing table of R3 and R3.

D*   192.168.1.0/24 [90/20512000] via 10.1.24.1, 00:00:14, Serial1/0

"* denotes default route pointing to network".
.





Make passive interface where EIGRP doesn't exist.

BB(config-router)#passive-interface default      //"making all interface passive"
BB(config-router)#no passive-interface serial 0/0     //"Making active interface"
BB(config-router)#no passive-interface serial 0/1    //"Making active interface"










"EIGRP" have befit over OSPF we can summarize network at any point but in OSPF we can summarize on border routers only.

BB(config-if)#ip summary-address eigrp 90 172.30.0.0 255.255.248.0   //"on both serial interface"


"After doing this on one interface look at routing table on both router and have a look on next hop on routes"







 
EIGRP is the only routing protocol which supports unequal load balancing.

BB(config-router)#variance 2


Now have a look on tables. And still have any doubt type in comment box.

Saturday, 4 January 2014

Basic VRRP Configuration

VRRP- Virtual Router Redundancy Protocol

I have written about HSRP in previous post. Today I am going to write on VRRP.
 

There are 3 main benefits to using VRRP over HSRP.
1.Open Standard (We can use any vendor's router)
2.Faster then HSRP
3.No need to give ip of any virtual router.

In VRRP we'll give ip of a router interface. So that router which interface we are going to use for VRRP will become Master.And there is no preemption because by default Master router have maximum priority (255) and Backup have 100. So if someone configure priority 255 of backup it'll not coop to become Master.

Topology--

  Simplest topology ever. 2 router (3600 Series) with a Ether Switch Module installed (NM-16ESW). 1 switch and one cloud in which I have configured loopback(ip-192.168.1.100192.168.1.100 and gateway 192.168.1.1) interface by this I can communicate from my PC.

Configuration-


1.Create vlan-50 on both router and give ip-




2.Now make Fast Ethernet member of VLAN-50--

R1(config)#int ran f 1/0 - 1
R1(config-if - range)#switchport mode access
R1(config-if-range)#switchport access vlan 50

and same on R2


R2(config)#int ran f 1/0 - 1
R2(config-if - range)#switchport mode access
R2(config-if-range)#switchport access vlan 50

3.Now configure VRRP on both Routers---

R1(config)#int vlan 50
R1(config-vlan)#vrrp 1 ip 192.168.1.1

After this command you will get a message-
"*Mar  1 00:01:08.439: %VRRP-6-STATECHANGE: Vl50 Grp 1 state Init -> Master"

It means your router become Master now time to configure R2 as R1-

R2(config)#int vlan 50
R2(config-vlan)#vrrp 1 ip 192.168.1.1

And after this command you will get a message-
"*Mar  1 00:01:06.283: %VRRP-6-STATECHANGE: Vl50 Grp 1 state Master -> Backup "

It means your R2 become Backup.

Testing-

To see vrrp Configuration type

R1#show vrrp


And to see configuration on R2  same command




Now try to ping 192.168.1.1 from you pc.




It is successful. Now shutdown vlan interface of R1 (On which we have configured 192.168.1.1).

 On R1 you will see a message--

And on R2-

So now your R2 become Master, now try to ping 192.168.1.1 again from pc--


And still you can see that we are able to ping.



 

Friday, 3 January 2014

EIGRP Neighborhood and Metric

EIGRP Neighborhood and Metric-

Neighborghood-


Metric Calculation -

1.Bandwidth (K1)                -1 By Default
2.Delay (K3)                       - 1 BY Default
3.Reliability (K4 and K5)     - 0 By Default
4.Loading (k2)                     - 0 By default
5.MTU (Maximum Transmission Unit)


Metric-

(K1 * BW +((K2 * BW) / (256- load)) + K3 * Delay ) * (K5/(Reliability + K4 ))

BW= 10^7/ BW
Delay= Delay in Microsecond

Real (Default Metric)-

256 * (Slowest_BW + All_Link_Delay)


Thursday, 2 January 2014

EIGRP TABLES AND TERMINOLOGY

EIGRP TABLES AND TERMINOLOGY

A Router running EIGRP maintains three tables-

1. Neighbor Table-
        By sending hello message EIGRP and OSPF create neighbor relationship and keep their information in Neighbor Table. If you talk about RIP then it doesn't create neighbor relationship it just send a multicast message and receive multicast messages of others.


2.Topology Table-
       OSPF contain all possible path in Topology Table but EIGRP contain only Successor and Feasible Successor in Topology Table. 


3.Routing Table-
      Like other routing protocol EIGRP also have Routing Table which contain best path.



Terminology-

   
In this topology I have 3 routers R0, R1 and R2 as you can see. R1 is connected to R0 with 100 Kb link and R0 is connected to R2 with 50 Kb link.I sitting om switch 0 with blink eye.:P

Now EIGRP will choose 100 Lb link as primary.And 50 Kb link as a Backup.

1.Feasible Distance (FD)-
       How far router from you. Lets cost from S0 to R1 and R2 is same that is 500. But Cost from R1 to R0 and R2 to R0 will be different because they both are connected with different speed link.Let cost for R1- R0 link is 1000 so cost for R2-R0 will we 2000.
      So FD for primary link is -500 + 1000 = 1500
     And FD for second link is  -1000 + 1000 = 2000


2.Advertise Distance (AD)-
      How far router is from your neighbor.

      So AD for primary and secondary is same - 1000

3.Successor - Primary link is called successor.

4.Feasible Successor - Backup link is called Feasible.

Note- "To be considered a Feasible Successor AD must be less then FD of successor.
Here AD is 1000 and FD of successor is 1500 so it'll become FS."



Note- " SO if EIGRP doesn't has FS in topology table and in case of link failure it send Query Message to it's neighbor. And if it's neighbor found that path from another neighbor or itself it'll reply with AD and if it doesn't found any path it'll reply with AD with infinity value (router will not choose this one)."

5.Active Router - 

       Router which actively looking for backup.(not a good thing.)

6.Passive Router -
      Router have at least one FS and everything is fine.
      

EIGRP Concept

EIGRP (Enhanced Interior Gateway Routing Protocol)

Today I'm going to talk about best routing protocol.That is EIGRP. It was Cisco Proprietary but in Mid-2013 it become open standard. Even it was very famous before become open standard.

Here are some reasons why I am saying it best-
 

1.Backup Routes-
           EIGRP contain Backup Routes in it's Topology table, so in case of any failure this Backup Route goes up.So what OSPF and IS-IS also have topology table and backup path also so why EIGRP???

          Yes right OSPF and IS-IS also have Topology table like EIGRP. But EIGRP have backup route as Feasible Successor (all pre-calculated paths in case of failure ) so in case of failure Feasible Successor become Successor in few millisecond. In OSPF and IS-IS they contains every possible path in topology table so in case of any failuer OSPF run SPF Algo. to calculate best path and it takes some time.


2.Simple Configuration-
         Configuration of EIGRP are very simple and easy to understand.

3.Flexibility in  Summarization -
         In OSPF there is only specific places like ABR, ASBR where you can summarize route, but in EIGRP you can summarize route at any point of network.


4.Unequal cost Load- Balancing -
        If you have to different bw connection and you want to do Load- balancing between them according to their bandwidth. For eg. I have two connection one is 2MPS and another is 1MBPS. And I want when I send 2 packet over 2 MBPS connection next packet should go on 1 MBPS or can say you want a packet sending ratio 2:1. So with help of EIGRP this is also possible.

5.Combines best of Distance Vector and Link State -

     That's a topic of debate.Book says it is Hybrid. Cisco says it is Advance Distance Vector but I say it simply Distance Vector. And I haven't said that believe me ... :P :D

Wednesday, 1 January 2014

Internal Components of a Cisco Router

The Internal Components of a Cisco Router

1)Bootstrap --
       Stored in the microcode of the ROM.It will boot the router and then load the IOS.

2)POST(Power On Self Test)--
      Stored in the microcode of the ROM, the POST is used to check the basic functionality of the router hardware and determines which interfaces are present.

3)ROM Monitor --
     Stored in the microcode of the ROM, the ROM monitor is used manufacturing, testing and troubleshooting.

4)Mini-IOS --
     RxBOOT or boot-loader, small IOS in ROM that can be used to bring up an interface and load a Cisco IOS into flash memory.

5)RAM --
    Used to hold packet buffers, ARP cache, routing table and also the software and data structure that allow the router to function.Store  Running-Configuration. Most router expend IOS from flash into RAM at time of boot.

6)ROM --
    Used to store and maintain the routes. Hold the POST and Bootstrap program as well as mini IOS.

7)Flash Memory --
    Store the Cisco IOS by default. Flash memory is not erased when the router is reloaded. It is EEPROM created by Intel.

8)NVRAM --
    Used to hold the router and switch configuration. NVRAM is not erased when the router or switch is reloaded. And NVRAM doesn't store an IOS. The configuration register is stored in NVRAM.

9)Configuration Register --
    Used to control how the router boot up. By default value is 0x2102, which tells the router to load the IOS from Flash Memory as well as load the configuration from NVRAM.